WhatPulse Forums
Whatpulse crash - Printable Version

+- WhatPulse Forums (http://whatpulse.org/forums)
+-- Forum: Support (/forumdisplay.php?fid=38)
+--- Forum: Client software (/forumdisplay.php?fid=58)
+--- Thread: Whatpulse crash (/showthread.php?tid=7832)



Whatpulse crash - [GoT]Jewest - 09-17-2019 07:15 AM

Warning: Ignoring XDG_SESSION_TYPE=wayland on Gnome. Use QT_QPA_PLATFORM=wayland to run on Wayland anyway.
17-09-2019 09:12:09.460 INFO "Starting WhatPulse 2.8.4-1633..."
QObject::startTimer: Timers cannot have negative intervals
17-09-2019 09:12:09.485 DEBUG Database file: "/home/<user>/.local/share/WhatPulse/whatpulse.db"
Application crashed with signal 11!
0 [/lib/x86_64-linux-gnu/libc.so.6(+0x15c759) [0x7fa6030a3759]]
1 [./whatpuls(+0x18d1d2) [0x5605e25ad1d2]]
2 [./whatpuls(sqlite3_vsnprintf+0x4a) [0x5605e25ad85a]]
3 [./whatpuls(sqlite3_snprintf+0x82) [0x5605e25ad8f2]]
4 [./whatpuls(+0x18d957) [0x5605e25ad957]]
5 [./whatpuls(+0x18dab8) [0x5605e25adab8]]
6 [/usr/lib/x86_64-linux-gnu/libsqlite3.so.0(+0x2fbab) [0x7fa604819bab]]
7 [/usr/lib/x86_64-linux-gnu/qt5/plugins/sqldrivers/libqsqlite.so(+0x8653) [0x7fa5f6008653]]
Aborted

any ideas?
Debian buster.


RE: Whatpulse crash - Mouseyy - 09-17-2019 01:33 PM

There was a thread related to this issue a while ago: https://whatpulse.org/forums/showthread.php?tid=8042 which got deleted (I wonder why)

It doesn't look like the developer is keen on supporting Linux clients. Also he's against open sourcing it because it can lead to people messing with the score/leaderboard... even though most of the users don't really care about that. Unfortunately this is the only "mainstream" tool for counting keys/clicks that is not marketed as a keylogger, so we'll have to make do with what we've got I guess.

Anyway, this has something to do with sqlite, I remember making this work a while ago but I can't recall all the details (maybe try whatpulse 2.8.3)

edit:

2.8.3: http://static.whatpulse.org/files/whatpulse-linux-ubuntu-64bit-2.8.3.tar.gz

You need qt4 and openssl-1.0 installed, then run with:
sudo LD_LIBRARY_PATH=/usr/lib/openssl-1.0 QT_X11_NO_MITSHM=1 ./whatpulse


RE: Whatpulse crash - [GoT]Jewest - 09-20-2019 09:22 AM

the needed libs:
linux-vdso.so.1 (0x00007ffd56736000)
libX11.so.6 => /usr/lib/x86_64-linux-gnu/libX11.so.6 (0x00007f81cc87c000)
libsqlite3.so.0 => /usr/lib/x86_64-linux-gnu/libsqlite3.so.0 (0x00007f81cc75a000)
libQt5Widgets.so.5 => /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5 (0x00007f81cc103000)
libQt5Gui.so.5 => /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5 (0x00007f81cbb78000)
libQt5Sql.so.5 => /usr/lib/x86_64-linux-gnu/libQt5Sql.so.5 (0x00007f81cbb2d000)
libQt5Network.so.5 => /usr/lib/x86_64-linux-gnu/libQt5Network.so.5 (0x00007f81cb98c000)
libQt5Xml.so.5 => /usr/lib/x86_64-linux-gnu/libQt5Xml.so.5 (0x00007f81cb94b000)
libQt5Core.so.5 => /usr/lib/x86_64-linux-gnu/libQt5Core.so.5 (0x00007f81cb450000)
libGL.so.1 => /usr/lib/x86_64-linux-gnu/libGL.so.1 (0x00007f81cb3bc000)
libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007f81cb39b000)
libstdc++.so.6 => /usr/lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007f81cb217000)
libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007f81cb094000)
libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007f81cb078000)
libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f81caeb7000)
libxcb.so.1 => /usr/lib/x86_64-linux-gnu/libxcb.so.1 (0x00007f81cae8d000)
libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007f81cae88000)
libpng16.so.16 => /usr/lib/x86_64-linux-gnu/libpng16.so.16 (0x00007f81cae4f000)
libharfbuzz.so.0 => /usr/lib/x86_64-linux-gnu/libharfbuzz.so.0 (0x00007f81cad54000)
libz.so.1 => /lib/x86_64-linux-gnu/libz.so.1 (0x00007f81cab34000)
libicui18n.so.63 => /usr/lib/x86_64-linux-gnu/libicui18n.so.63 (0x00007f81ca859000)
libicuuc.so.63 => /usr/lib/x86_64-linux-gnu/libicuuc.so.63 (0x00007f81ca68a000)
libpcre2-16.so.0 => /usr/lib/x86_64-linux-gnu/libpcre2-16.so.0 (0x00007f81ca60f000)
libdouble-conversion.so.1 => /usr/lib/x86_64-linux-gnu/libdouble-conversion.so.1 (0x00007f81ca5f8000)
libglib-2.0.so.0 => /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0 (0x00007f81ca4d7000)
/lib64/ld-linux-x86-64.so.2 (0x00007f81cd005000)
libGLX.so.0 => /usr/lib/x86_64-linux-gnu/libGLX.so.0 (0x00007f81ca4a3000)
libGLdispatch.so.0 => /usr/lib/x86_64-linux-gnu/libGLdispatch.so.0 (0x00007f81ca3e6000)
libXau.so.6 => /usr/lib/x86_64-linux-gnu/libXau.so.6 (0x00007f81ca1e2000)
libXdmcp.so.6 => /usr/lib/x86_64-linux-gnu/libXdmcp.so.6 (0x00007f81c9fdc000)
libfreetype.so.6 => /usr/lib/x86_64-linux-gnu/libfreetype.so.6 (0x00007f81c9f20000)
libgraphite2.so.3 => /usr/lib/x86_64-linux-gnu/libgraphite2.so.3 (0x00007f81c9ef1000)
libicudata.so.63 => /usr/lib/x86_64-linux-gnu/libicudata.so.63 (0x00007f81c8501000)
libpcre.so.3 => /lib/x86_64-linux-gnu/libpcre.so.3 (0x00007f81c848d000)
libXext.so.6 => /usr/lib/x86_64-linux-gnu/libXext.so.6 (0x00007f81c827b000)
libbsd.so.0 => /usr/lib/x86_64-linux-gnu/libbsd.so.0 (0x00007f81c8261000)
librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007f81c8255000)


RE: Whatpulse crash - [GoT]Jewest - 10-28-2019 01:18 PM

?? no reply ??