WhatPulse Forums
[FIXED] WhatPulse 2.6: Mac OSX 10.9.5 Segmentation fault: 11 - Printable Version

+- WhatPulse Forums (http://whatpulse.org/forums)
+-- Forum: Support (/forumdisplay.php?fid=38)
+--- Forum: Client software (/forumdisplay.php?fid=58)
+--- Thread: [FIXED] WhatPulse 2.6: Mac OSX 10.9.5 Segmentation fault: 11 (/showthread.php?tid=6507)



[FIXED] WhatPulse 2.6: Mac OSX 10.9.5 Segmentation fault: 11 - denisk20 - 05-14-2015 08:49 AM

Running Mac OSX 10.9.5 64-bit.
After upgrading to 2.6 WhatPulse fails to start. When I run

/Applications/WhatPulse.app/Contents/MacOS/whatpulse

manually I get this output:

4-05-2015 11:38:11.155 INFO "Starting WhatPulse 2.6..."
14-05-2015 11:38:11.163 DEBUG Database file: "/Users/dkniaz/Library/Application Support/WhatPulse/whatpulse.db"
14-05-2015 11:38:11.165 DEBUG Database check: "ok"
14-05-2015 11:38:11.166 DEBUG Opened database in: 3 ms
14-05-2015 11:38:11.170 DEBUG Encrypted file: "/Users/dkniaz/Library/Application Support/WhatPulse/whatpulse.wpw"
Segmentation fault: 11

If I run

rm ~/Library/Application\ Support/whatpulse/whatpulse.wpw
rm ~/Library/Application\ Support/whatpulse/whatpulse.wpw.backup

then it starts, but asks me for credentials and computer name. On a restart everything reoccurs.

What's the issue here?


RE: WhatPulse 2.6: Mac OSX 10.9.5 Segmentation fault: 11 - smitmartijn - 05-15-2015 10:19 PM

Hi,

Could you run the client with --verbose as parameter? So: "/Applications/WhatPulse.app/Contents/MacOS/whatpulse --verbose" (minus quotes)

If there's a "get_facebook_login" in the final sentence it's an issue that's universal to OSX/Windows/Linux and should be fixed very soon (waiting on confirmation from other people).


RE: WhatPulse 2.6: Mac OSX 10.9.5 Segmentation fault: 11 - wonder_al - 05-16-2015 02:29 AM

Yep that's the problem:

15-05-2015 21:28:41.788 TRACE Settings::get( "login_via_facebook" )
Segmentation fault: 11


RE: WhatPulse 2.6: Mac OSX 10.9.5 Segmentation fault: 11 - smitmartijn - 05-16-2015 10:42 AM

Version 2.6.1 has just been posted to fix this. Use the updater or download from http://whatpulse.org/downloads/