WhatPulse Forums
Linux client requiring GLIBC_2.14 - Printable Version

+- WhatPulse Forums (http://whatpulse.org/forums)
+-- Forum: Support (/forumdisplay.php?fid=38)
+--- Forum: Client software (/forumdisplay.php?fid=58)
+--- Thread: Linux client requiring GLIBC_2.14 (/showthread.php?tid=2162)



Linux client requiring GLIBC_2.14 - hostname - 12-29-2012 10:48 PM

Is there any reason for the Linux client to require glibc 2.14? It doesn't seem to use any of its features, and it blocks usage on Debian Wheezy.


RE: Linux client requiring GLIBC_2.14 - houkouonchi - 12-30-2012 02:11 AM

(12-29-2012 10:48 PM)hostname Wrote:  Is there any reason for the Linux client to require glibc 2.14? It doesn't seem to use any of its features, and it blocks usage on Debian Wheezy.


Indeed. It always annoy's me when binary-only releases do not make static build binaries and build off older versions of glib to support more distro's/systems. I have to run mine out of an ubuntu chroot environment.


RE: Linux client requiring GLIBC_2.14 - smitmartijn - 12-30-2012 09:45 AM

The reason is that the client was built on Qt 4.8 (minimal 4.7) - which is also not available on Debian. Any modern distribution has up to date packages, which is why I decided to put this out there now and see if it's back portable on a later date.


RE: Linux client requiring GLIBC_2.14 - MAX3400 - 12-30-2012 11:59 AM

Totally off-topic but I wonder how WhatPulse chooses NOT to support Debian Squeeze (about 3 years old) vs. DO supporting Windows XP (about 12 years old). Speaking of modern distro's/OS's.


RE: Linux client requiring GLIBC_2.14 - smitmartijn - 12-30-2012 12:14 PM

(12-30-2012 11:59 AM)MAX3400 Wrote:  Totally off-topic but I wonder how WhatPulse chooses NOT to support Debian Squeeze (about 3 years old) vs. DO supporting Windows XP (about 12 years old). Speaking of modern distro's/OS's.

Quick answer; Windows does backwards compatibility pretty good, so all the Windows code is the same for XP, Vista, 7, 8. The 'biggest' issue here is Qt; the client needs at least 4.7. Qt 4.7 is 2 years old, which is pretty reasonable for me to have updated your packages to it, but I guess Debian has a different release schedule.

Once I have time to rearrange some Qt code so it can be compiled with 4.6, there will be a Debian release.


RE: Linux client requiring GLIBC_2.14 - hostname - 12-30-2012 12:25 PM

(12-30-2012 09:45 AM)smitmartijn Wrote:  The reason is that the client was built on Qt 4.8 (minimal 4.7) - which is also not available on Debian. Any modern distribution has up to date packages, which is why I decided to put this out there now and see if it's back portable on a later date.

That's not true. Debian Wheezy includes Qt 4.8.2. I understand that you don't want to support Squeeze (which will be obsolete in a few months anyway), but Wheezy is a modern distribution with up to date packages.


RE: Linux client requiring GLIBC_2.14 - smitmartijn - 12-30-2012 12:33 PM

Well, apparently the main download is not this Wheezy, so I'm guessing most Debian users won't have that version.

So Wheezy has later versions of software packages, but they scrapped it for older software on the main train? Doesn't make much sense to me..


RE: Linux client requiring GLIBC_2.14 - hostname - 12-30-2012 12:50 PM

No. Debian Squeeze (Debian 6.0) is the current stable (released) version. Debian Wheezy (Debian 7.0) will be the next stable version (called "testing"), and is currently in the final pre-release stage. It'll probably be released somewhere around March.

However, due to the ultimate stability Debian aims for, even the pre-release versions are very stable and often a lot more stable than other distributions. Ubuntu LTS releases are actually based upon the Debian testing version (the normal releases are based upon unstable, which is the development version). See Wikipedia for more information about the release schedule.

Almost all desktop users run the testing or unstable version, because the stable version is too old and the testing version is very stable too, while stable is mainly used on servers. Thus, most users of WhatPulse on Debian will have Qt 4.8.