WhatPulse Forums » Feature requests » Website v » Website does not work on Macs (10.6) Welcome back, Guest.


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Website does not work on Macs (10.6)
10-03-2009, 07:34 PM,
#1
Website does not work on Macs (10.6)
I have tried both Safari and Firefox (both very popular browsers on the Mac OS) and each time I have been met with errors from this website.


1) When I visit the page all appears okay but for whatever reason this text appears at the top of the page:

Quote:Warning: session_start() [function.session-start]: Cannot send session cookie - headers already sent by (output started at /home/www/whatpulse.org/www/includes/pulse.php:1504) in /home/www/whatpulse.org/www/includes/pulse.php on line 59

Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /home/www/whatpulse.org/www/includes/pulse.php:1504) in /home/www/whatpulse.org/www/includes/pulse.php on line 59

This text will persist on almost every other page on the website.

2) Trying to download a version of what pulse from the downloads page is a futile attempt. Because this error appears each and every time for each and every download link.

Quote:Warning: Cannot modify header information - headers already sent by (output started at /home/www/whatpulse.org/www/includes/pulse.php:1504) in /home/www/whatpulse.org/www/pg/downloads.php on line 19

*I had to come into the forums to find a direct link to a prerelease in order to actually get the application on my computer.

3) When I try to login on the website it takes me to a page which first says "Login Successful" and then after 5-10 seconds it redirects me to another page which says "Sorry, you need to be logged in to view this page.". No matter how many times I log in, I get this message over and over again. Why does it keep logging me out immediately after I have logged in?

4) This inability to log in prevents me from joining teams, I assume, because I can't see any button or field to type in a password to join a team. I was expecting such an option when I logged in but I cannot log in so the effort seems wasted on this buggy site.

5) I am wondering if there are any plans to remedy these errors or should I not hold my breath? Is this just a problem with the 10.6 Mac operating system trying to display your webpage or did something happen on your end which has caused the problem? Will you be updating your code to account for the new Mac OS or will you be recommending that people stick with older versions if they want to use What.Pulse or join a What.Pulse team?
10-03-2009, 08:19 PM,
#2
Website does not work on Macs (10.6)
Problems like this (header errors) aren't related to browsers or OS's, they are a problem with the website code and affect all browsers and OS's. As for the not logging in problem, usually that's a problem with sessions/cookies/proxies/IPs on your end (one of the four, not sure what one!). Logging in does work, however. I'm sure Century0 will know what to do!

I've alerted the people in charge of website management and they'll get onto the header issue asap.

Thanks for bringing this to our attention and thanks for your patience!
10-04-2009, 04:56 AM,
#3
Website does not work on Macs (10.6)
Enable cookies.

~Century0
10-10-2009, 09:24 AM,
#4
Website does not work on Macs (10.6)
Just to clarify; it was my bad. Most of the whatpulse things are developed on a Mac, so it's more likely something won't work on windows than the other way around. ;-)


Possibly Related Threads…
Thread Author Replies Views Last Post
Lightbulb Some website suggestions / glitches Bloopy 0 3,926 12-03-2013, 12:57 AM
Last Post: Bloopy

Forum Jump:


Users browsing this thread: 1 Guest(s)