Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[CLOSED] WhatPulse not working in some apps where used to work before
WhatPulse is acting weird from few last updates. First I noticed it doesn't count keys when playing GTA V but it used to do so a first few days. I thought this is due to GTA V because I'm using cracked game and also my multimedia keys don't work while the game is running.

But I also noticed it doesn't count my keys in VMWare as well, but it used to do before. Can you please fix this? I'm playing GTA V a lot and also I'm using Ubuntu in VMWare a lot, for example today I spend the whole day coding and it probably missed more than 20 000 key counts Sad

I installed WhatPulse as the first app when I bought my laptop so since this problems, it probably got all my keypresses ever and now it messed everything up.

One of the reasons why it wouldn't count inside games is that the game hog the input or the client isn't running as administrator (default is normal user, there's a setting to elevate it to admin). If it's the first, it simply cannot count inside the game.

As for counting inside will count inside the guest OS if you have the client there, but it won't count on the host OS. This is by design to prevent double counting.
As far as I know, WhatPulse was never intended to count local inputs while in VMWare. I'm assuming that this is an anti-cheat method, to prevent people from cheating by getting input from the local machine as well as the virtualized one.

Looks like Martijn beat me to it while I was typing this post up.

Are you running WhatPulse as an Administrator? (Check to ensure that the "Run As Administrator" box is checked in Settings. If not, then check it, save your settings and restart the client.) Running as Admin may help you to catch the keys from GTA V.

If that doesn't work, try running GTA V in windowed mode.

If the above solutions don't work, then maybe there's something wonky going on with your cracked game copy, as over 2,500 users have counted input from GTA V. ( )

Not sure what you're implying in your last paragraph.
I read about hogging the input but as I said, after installing GTA V it worked for first few days and then it stopped counting. It also works on GTA IV (at least it used to work before, I haven't played it for months). And about WMvare, it also worked before so you removed this after latest updates or what? I don't like this idea, it would be better that we can choose in Settings whether we want to count on host OS or not. The main reason for using WMware instead dual boot is to avoid installing some programs that are already on Windows, including PulseAudio, audio equalizer and others, so I can install any OS as a virtual machine and be sure that WhatPulse will count keys and clicks, that sound will be equalized etc. without the need to install all these apps in guest OS again. Also I'm using lots of guest OSes, like Ubuntu, Win XP, Win 7 and I used to have OSX too so it's not very practical to install WP on each of them.

Run as Administrator is checked and I'm also starting the game as administrator. I'm not sure what windowed mode is, but I know that my game always starts as a window and then I have to press ALT+ENTER (or CTRL+ENTER) to get full screen.

With the last paragprah I wanted to say that I used WhatPulse as a kind of "odometer" for laptop Big Grin It was first program installed after Windows on my new laptop and the goal was to count every key press ever made on this laptop since I bought it, like every car counts kilometers. I know, it sounds weird, but I'm some kind of statistical freak. And now when there are some apps when it won't count, it's like a car doesn't count kilometers on some roads so you can't say anymore that your car has, for example, exactly 100k kilometers, and you don't know anymore the exact number of kilometers, since it didn't count everything. It can be 110k, or 120k or who knows...
When it comes to work before and now not working; the application in questions would have gotten an update that is causing it. The counting mechanism the WhatPulse client hasn't changed in years, so this wasn't changed in a WhatPulse update.

As for the car and kilometer comparison, think of these applications that hog input like a ferry boat, which still make the car move kilometers, but hog the movement part. Cars usually travel more then that's on their odometers.
But car doesn't use it's own engine to move while on ferry boat, nor his wheels move. When in virtual machine, I still use all the laptop's hardware and the same keyboard so yes, it would be good to get it working so I don't have to install on all those guest OS'es. VMWare is an app running on windows like any other app. There's absolutely no difference if I type in MS Word, in Chrome or in VMWare. At least, I use it like this. I'm playing music in Windows, browsing internet in windows and coding in Ubuntu at the same time, so I use WMWare like any other Windows app.

If nothing has changed, then it should work because it worked before. Maybe a local problem, so I should try to reinstall the app or something.
There's a significant change between typing in Word and in VMware or any other input locking app. You're simply not going to get it to work and it has not worked in the past.
(05-20-2015, 06:29 PM)smitmartijn Wrote: You're simply not going to get it to work and it has not worked in the past.

Hmm, what about this: ? The keycount should be bigger because I used it more, but I surely haven't pressed 30k times in WMware start screen. The only thing that comes to my mind is that it counts CTRL+TAB and CTRL+ALT because I'm passing all the time between WMware and other windows apps.
About GTA V, it's been the same for me in 2.5 and 2.6, it normally doesn't count the keys, but to get it to count basically you have to start GTA V first, then start whatpulse after the game is running. You have to do it again every time you restart GTA V.

This might work with other applications that normally don't count the keys, the input hook is probably re-taken by whatpulse when you start it after the game.

EDIT: I just tried this method with 2 other applications that wouldn't count keys for me in the past, and it worked. I don't know why I thought of this for GTA but not for other things, lol.

This issue could probably be fixed if whatpulse would detect when it loses the input hook and restarts it, or something.
Thank you, I'll try it. And now I think that I understand why it worked before on GTA V. First crack that I was using required adjusting system clock a few days backwards but this would mess my WhatPulse heatmap so I would close WhatPulse, turn back the time (lol), launch the game, put the time back and then launch WhatPulse again and then play the game. So this is probably the reason why it worked before.

Possibly Related Threads…
Thread Author Replies Views Last Post
  Cannot log in on Whatpulse client riddl3r 0 259 Yesterday, 06:10 AM
Last Post: riddl3r
  WhatPulse slow loading, massive HDD usage Redirect Left 0 192 01-11-2022, 03:34 AM
Last Post: Redirect Left
  Whatpulse restarting several times cavveman 2 243 01-10-2022, 05:28 PM
Last Post: cavveman
  I can't use new versions "WhatPulse". Fluttermina 9 719 01-09-2022, 02:31 PM
Last Post: Fluttermina
  Whatpulse is not tracking anything on linux Xabec 2 770 11-29-2021, 09:08 AM
Last Post: Xabec
  Whatpulse client backup: Access is denied. Galaxied 1 788 11-28-2021, 10:31 AM
Last Post: smitmartijn
  WhatPulse on Ubuntu not recording network metrics [solved] Code-E 2 787 11-03-2021, 10:29 PM
Last Post: Code-E
  WhatPulse randomly stop tracking keyboard strokes anandinasu 0 620 09-29-2021, 03:37 AM
Last Post: anandinasu
  Whatpulse 3.2 on Ubuntu 21.04 Lieutenant_Dan 3 1,748 09-10-2021, 11:30 AM
Last Post: kitliasteele
  [SOLVED] WhatPulse Refuses to Start automatically. iisacc 11 14,509 08-23-2021, 09:45 PM
Last Post: Tealdragon204

Forum Jump:

Users browsing this thread: 1 Guest(s)