Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Debian] Pulses lost when using reboot command

I was about to pulse a small (10K key) pulse from my machine till I found out that it was lost.
So I tried to figure out what is going wrong.

Perform the following sequence:
1]. Boot Dedian x64 with whats app client version 2.5
2]. Type about 90 chars. (or any other number)
3] open a terminal.
4]. sudo reboot
5]. reboot the machine
6] check the unpulsed state for the client, this is zero instead of 90.
But the Hotkey map is reporting that there are 90 keys today.
Please solve this issue or explain why this is not working as expected..

Thank you in advance.
It's kinda working as expected.."sudo reboot" doesn't give apps to shutdown properly, the system just goes. The client doesn't have the chance to save, that's why. If you reboot through the window manager shutdown, it'll give apps the chance to shutdown properly (that depends on the window manager again though..).
I agree and disagree.
My assumption was/is that the whatspulse application would store every <fill in a time frame>.
So that there would be a loss but less then all.
Maybe a configurable option for the next generation?
It does, every 15 minutes. If it does it more then 15 minutes, it'll take disk performance away from your regular applications. The time it'll take you to type 90 characters is probably less than 15 minutes. :-)

It's not going to be a configurable option, mostly because it can cause issues with a users system.

Possibly Related Threads…
Thread Author Replies Views Last Post
Question 3.0 Reboot Calendar not working Xylion 0 991 01-03-2021, 10:08 PM
Last Post: Xylion
Sad cant recognize the command key on mac zhangruiqi 2 3,980 05-09-2020, 05:31 PM
Last Post: Anonymous2
  [CLOSED] Debian Stretch: OpenSSL library not found wullxz 1 3,312 02-27-2017, 05:31 PM
Last Post: smitmartijn
  Favorite reboot days dots are too small d3ullist 3 3,968 11-05-2016, 10:36 PM
Last Post: smitmartijn
  Favorite reboot days is massive d3ullist 1 2,837 03-22-2016, 06:25 PM
Last Post: smitmartijn
  [SOLVED] Duplicate Pulses (Client Version 2.5) abpop 2 4,356 01-03-2015, 07:59 AM
Last Post: abpop
  Heat map is not showing Enter button in Debian Testing(Jessie) and version 2.3 [GoT]Jewest 1 5,279 02-20-2014, 10:18 PM
Last Post: cartman2000
  Lost 12k clicks when exiting and reloading buggy client trbot 2 6,095 02-01-2014, 11:15 PM
Last Post: trbot
  WhatPulse lost past keyboard pushes/clicks also unpulsed issue JantsoP 1 7,392 10-19-2013, 10:47 AM
Last Post: smitmartijn
Sad I just updated and lost all of my clicks Ryan_Hogan 3 6,382 09-22-2013, 08:48 PM
Last Post: smitmartijn

Forum Jump:

Users browsing this thread: 1 Guest(s)