WhatPulse Forums » Support » Client software v » SSL Handshake Error Welcome back, Guest.


Post Reply 
 
Thread Rating:
  • 1 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
SSL Handshake Error
02-08-2020, 03:23 PM
Post: #1
Question SSL Handshake Error
(Description first, versions below)

I've started receiving the following error dialogue when attempting to report a pulse back:

> Error while talking to website: SSL handshake failed. We recommend trying again in a little while.

My browser and curl don't seem to have problems with the SSL cert on whatpulse.org. However, running whatpulse under dtruss, I saw the following output on attempt to open browser for login:

08-02-2020 10:17:30.497 DEBUG SSL Errors:
08-02-2020 10:17:30.498 DEBUG "The issuer certificate of a locally looked up certificate could not be found"
08-02-2020 10:17:30.498 DEBUG "The root CA certificate is not trusted for this purpose"
08-02-2020 10:17:30.498 DEBUG "No certificates could be verified"
08-02-2020 10:17:30.498 WARN void ClientCommunication::checkHTTPError(QString) Error: "Error while talking to website: SSL handshake failed. We recommend trying again in a little while."

WP version: 2.8.4
OS: $ uname -a
Darwin [hostname] 18.7.0 Darwin Kernel Version 18.7.0: Sun Dec 1 18:59:03 PST 2019; root:xnu-4903.278.19~1/RELEASE_X86_64 x86_64
Find all posts by this user
Quote this message in a reply
02-08-2020, 04:09 PM
Post: #2
RE: SSL Handshake Error
Me too, on both my Desktop and Notebook.
Find all posts by this user
Quote this message in a reply
02-08-2020, 06:24 PM
Post: #3
RE: SSL Handshake Error
Same here
Windows 10
Client: 2.8.4
Find all posts by this user
Quote this message in a reply
02-08-2020, 07:22 PM
Post: #4
RE: SSL Handshake Error
Had a same issue, restarting a application seems to solve the problem.

https://twitter.com/whatpulse/status/122...7789220864
Find all posts by this user
Quote this message in a reply
02-08-2020, 10:22 PM
Post: #5
RE: SSL Handshake Error
A system restart allowed a pulse after this error but the error returned when testing using a manual pulse. Curious issue, to the aps credit it has been a long time since I have encountered any issues.
Find all posts by this user
Quote this message in a reply
02-09-2020, 09:12 AM
Post: #6
RE: SSL Handshake Error
In my Mac and in some Windows machine I still receiving the message. I've also seen some 503 error in this website. Hope the issue will be fixed soon
Find all posts by this user
Quote this message in a reply
02-09-2020, 10:25 AM (This post was last modified: 02-09-2020 10:41 AM by jedrys.)
Post: #7
RE: SSL Handshake Error
Same problem here on my Mac, even after restarting the app a few times. Please fix Smile

I've just noticed that after restarting I cannot even log in using my client - same error
Find all posts by this user
Quote this message in a reply
02-09-2020, 05:47 PM
Post: #8
RE: SSL Handshake Error
Hey folks. We're looking into the problem, I'm having it myself!
Visit this user's website Find all posts by this user
Quote this message in a reply
02-09-2020, 06:59 PM
Post: #9
RE: SSL Handshake Error
Please give it some time. The caching time seems different per computer; but it will be cleared eventually and you'll be able to pulse. All stats are simply kept a little longer on the client in the meantime.
Visit this user's website Find all posts by this user
Quote this message in a reply
02-10-2020, 06:00 PM
Post: #10
RE: SSL Handshake Error
Now is working fine for my Mac. Just to give you a feedback. Thanks for the job!
Find all posts by this user
Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
Question [Win7x64 WP2.5] Error while pulsing: "Wrong Password! Try again." Diamundo 9 4,896 01-18-2020 12:08 PM
Last Post: Megachip
  Server error: Missing input! with whatpulse 2.8.4 on Win10 Franck.Dernoncourt 3 1,557 09-24-2019 10:56 PM
Last Post: kolah
Bug server error sggxp 0 731 04-25-2019 04:50 AM
Last Post: sggxp
  [SOLVED] Error uploading keyboard/mouse heatmap Wopian 2 1,687 03-17-2017 12:26 PM
Last Post: Wopian
  [SOLVED] [postmortem] Pulse error: "The specified configuration cannot be used." dgw 4 2,965 03-03-2017 09:54 PM
Last Post: dgw
  [FIXED] SSL Handshake Error JetSet 9 3,762 01-09-2017 09:39 AM
Last Post: AmokOwe
  Server Error Missing INput Please COntact the Developers arsha99 1 2,236 07-01-2015 07:41 PM
Last Post: smitmartijn
  error : Wrong password! Try again wazup 2 3,974 06-01-2015 08:42 AM
Last Post: smitmartijn
  Server Error: Missing Input tboxley 2 3,015 05-26-2015 07:22 PM
Last Post: smitmartijn
Sad [CLOSED] Windows XP Error: failed to initialize properly BiblePreacher 2 3,130 05-24-2015 08:24 AM
Last Post: BiblePreacher

Forum Jump:


User(s) browsing this thread: 1 Guest(s)