WhatPulse Forums » Support » Client software v » [Edited] Whatpulse does not work with libssl-dev 1.1.0 Welcome back, Guest.


Post Reply 
 
Thread Rating:
  • 1 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Edited] Whatpulse does not work with libssl-dev 1.1.0
12-12-2016, 09:57 PM (This post was last modified: 12-15-2016 04:49 AM by jhepburn.)
Post: #1
[Edited] Whatpulse does not work with libssl-dev 1.1.0
Greetings,

This has started happening on two different computers both running Debian Testing:

Whatpulse 2.7.1 fails with the message "AES functions not available. Is OpenSSL library present?"

Normally, this seems to be a failure to have libssl-dev installed. I have libssl-dev 1.1.0 installed.

[Edited] I have downgraded to libssl-dev 1.0.1 and Whatpulse runs perfectly again - but to continue counting keystrokes, I had to pulse, then delete my local data files and start afresh.

Jonathan
Find all posts by this user
Quote this message in a reply
01-08-2017, 09:07 PM
Post: #2
RE: [Edited] Whatpulse does not work with libssl-dev 1.1.0
I'm getting exactly the same issue on Kali Linux. Not much point in reverting to libssl-dev 1.0.1 either because of dependencies.
Find all posts by this user
Quote this message in a reply
01-09-2017, 05:44 PM
Post: #3
RE: [Edited] Whatpulse does not work with libssl-dev 1.1.0
I'm having the same issue, also on debian testing. The worst thing is that since whatpulse doesn't run, I won't be notified when they'll release 2.7.2 which will hopefully fix the error.
Find all posts by this user
Quote this message in a reply
02-27-2017, 05:26 PM
Post: #4
RE: [Edited] Whatpulse does not work with libssl-dev 1.1.0
The latest debian version still seems to be used libssl 1.0.0. Same goes for Ubuntu. This means the next client version will still be linked to libssl 1.0.0.

What happens when you symlink the new libssl.so.1.1.0 to the old libssl.so.1.0.0?
Visit this user's website Find all posts by this user
Quote this message in a reply
03-07-2017, 11:11 PM
Post: #5
RE: [Edited] Whatpulse does not work with libssl-dev 1.1.0
Problem i have is when i upgrade Kali OS it installs libssl-dev 1.1.0, will have to see if i can install 1.0.0 alongside 1.1.0 without breaking stuff
Find all posts by this user
Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  WhatPulse randomly stop tracking keyboard strokes anandinasu 0 146 09-29-2021 03:37 AM
Last Post: anandinasu
  Whatpulse 3.2 on Ubuntu 21.04 Lieutenant_Dan 3 907 09-10-2021 11:30 AM
Last Post: kitliasteele
  [SOLVED] WhatPulse Refuses to Start automatically. iisacc 11 12,558 08-23-2021 09:45 PM
Last Post: Tealdragon204
  Whatpulse doesn't track internet up/down correctly on gigibit internet Deuss 2 376 08-19-2021 08:32 PM
Last Post: lvh1
  Whatpulse client stops tracking keys Sylverblack 0 270 08-04-2021 04:31 PM
Last Post: Sylverblack
  WhatPulse error on Linux (Elementary-OS 6) Suxhe 0 439 06-13-2021 10:56 PM
Last Post: Suxhe
  whatpulse is writing to database every second minho 1 668 06-11-2021 07:00 PM
Last Post: Alexey..Zubenko
Question Autostart WhatPulse 3.1 without Confirmation (Win10) blankster 0 688 04-04-2021 04:53 PM
Last Post: blankster
Question Can't install WhatPulse 3.1 correctly (Win10) blankster 0 688 04-04-2021 04:49 PM
Last Post: blankster
  When you switch networks WhatPulse stops tracking bandwidth TheEliteFriendsYT 2 1,211 04-01-2021 10:05 AM
Last Post: TheEliteFriendsYT

Forum Jump:


User(s) browsing this thread: 1 Guest(s)