WhatPulse Forums » Support » Client software v » [Linux] Inaccurate download numbers Welcome back, Guest.


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Linux] Inaccurate download numbers
03-03-2016, 06:22 PM (This post was last modified: 03-07-2016 10:47 PM by Frogging101.)
Post: #1
[Linux] Inaccurate download numbers
If I download a 60MB file (such as this one), WhatPulse will only count about about 6MB. Additionally, Firefox/wget will report downloading at 5.4MB/s while Whatpulse thinks it's only 600kB/s. Uploading doesn't seem to suffer this problem; I can rsync the file to my server at 10MB/s and Whatpulse will count it properly. But then when I pull it down again with rsync at 4MB/s, Whatpulse will only count about 300kB/s (and upload/download totals will be similarly skewed).

I don't know if this issue happens only on my laptop or not. I'll try it on my desktop too.
Find all posts by this user
Quote this message in a reply
03-04-2016, 06:59 PM
Post: #2
RE: [Linux] Inaccurate download numbers
Doesn't seem to happen on my desktop with the same version of Whatpulse. Hmm.
Find all posts by this user
Quote this message in a reply
03-05-2016, 09:09 PM
Post: #3
RE: [Linux] Inaccurate download numbers
Using WhatPulse on servers are not supported and against our ToS. Can't help you with that one.
Visit this user's website Find all posts by this user
Quote this message in a reply
03-07-2016, 10:44 PM (This post was last modified: 03-07-2016 10:47 PM by Frogging101.)
Post: #4
RE: [Linux] Inaccurate download numbers
(03-05-2016 09:09 PM)smitmartijn Wrote:  Using WhatPulse on servers are not supported and against our ToS. Can't help you with that one.

You misunderstand. I'm using it on my laptop (this one, in fact). I was testing the issue by downloading/uploading files to/from my server. WhatPulse is on the laptop, not on the server.

"Other server" was a typo, so I'll fix that.
Find all posts by this user
Quote this message in a reply
03-10-2016, 08:57 PM
Post: #5
RE: [Linux] Inaccurate download numbers
(03-07-2016 10:44 PM)Frogging101 Wrote:  "Other server" was a typo, so I'll fix that.

Ah, that makes sense. This server, is this located on the internet or on your local network?

Some references:
http://help.whatpulse.org/kb/website/wha...he-website
http://help.whatpulse.org/kb/client/my-n...t-counting
Visit this user's website Find all posts by this user
Quote this message in a reply
03-13-2016, 10:41 PM
Post: #6
RE: [Linux] Inaccurate download numbers
(03-10-2016 08:57 PM)smitmartijn Wrote:  
(03-07-2016 10:44 PM)Frogging101 Wrote:  "Other server" was a typo, so I'll fix that.

Ah, that makes sense. This server, is this located on the internet or on your local network?

Some references:
http://help.whatpulse.org/kb/website/wha...he-website
http://help.whatpulse.org/kb/client/my-n...t-counting

This test was being done over the Internet. If it were a local network issue I'd think that none of that data would be counted, rather than some of it being counted.
Find all posts by this user
Quote this message in a reply
03-17-2016, 06:07 PM
Post: #7
RE: [Linux] Inaccurate download numbers
Happens for me as well on Arch Linux with WP 2.7 and Intel 8260 WiFi: No matter what files I download (all from the internet), be it packages from the Arch repository or some file on the web. For Example, I've just downloaded ~600MB of packages, and the download counter in the WhatPulse-Application increased by only ~90MB. My connection speed is ~9-10 MB/s, libpcap is installed. Any ideas?
Find all posts by this user
Quote this message in a reply
04-13-2016, 06:55 PM
Post: #8
RE: [Linux] Inaccurate download numbers
No ideas anyone? It's quite annoying...
Find all posts by this user
Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  Having trouble running whatpulse on Neon Linux BlackWidow 1 73 12-03-2019 12:02 AM
Last Post: Adrriii
  Upload and download swapped Nick3252 0 233 07-23-2019 06:00 PM
Last Post: Nick3252
  [SOLVED] Can't run the Linux version [Driver not loaded Driver not loaded] radioz 2 1,130 06-20-2019 11:54 AM
Last Post: radioz
  WhatPulse not opening on Manjaro Linux (Arch distro) tboxley 4 820 05-26-2019 11:30 AM
Last Post: FamilienVater
  Incorrect Network Upload/Download cahern7 11 3,545 11-21-2016 07:13 PM
Last Post: smitmartijn
  [CLOSED] Does whatpulse linux support Qt5 satshow 1 1,261 06-26-2016 06:19 PM
Last Post: smitmartijn
  [CLOSED] Installing on ARM Based Linux London_Ash 3 3,901 05-01-2016 11:42 PM
Last Post: Wopian
  Help for Linux version angelo.gallesio 0 674 04-27-2016 11:26 AM
Last Post: angelo.gallesio
  [Linux] 0Gb Down 0Gb Up Alkaris 1 786 03-12-2016 11:33 PM
Last Post: Wopian
  [SOLVED] upload and download not updating correctly windows 8.1 MrLinuxFish 1 1,174 02-10-2016 06:20 PM
Last Post: smitmartijn

Forum Jump:


User(s) browsing this thread: 1 Guest(s)