WhatPulse Forums » Support » Client software v » [SOLVED] WP 2.1.1 AES function not available??? Welcome back, Guest.

Post Reply 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] WP 2.1.1 AES function not available???
05-20-2013, 10:01 AM (This post was last modified: 05-20-2013 07:48 PM by Dokter Computer.)
Post: #1
[SOLVED] WP 2.1.1 AES function not available???
Hi all,

I'd have never a problem with running whatpulse but this time there is a problem. On every boot Whatpulse suppose to be running. But now it is saying:

AES functions not available. Is OpenSSL library present?

I found another topic about this error, however I'm not running windows server software. This is what i run:

- Ubunut 13.04 x32
- Cinnamon desktop 1.8.2

To the best of my knowledge there is no software that can interfere with whatpulse (it never did) except OpenSSH server. I have no anti-virus or what-so-ever running. Also I checked on the error of having any libs installed regarding openssl.

user@user-laptop:~$ sudo dpkg --list | grep libssl
ii libssl1.0.0:i386 1.0.1c-4ubuntu8 i386 SSL shared libraries

I ran the same command for openssl:

user@user-laptop:~$ sudo dpkg --list | grep openssl
ii openssl 1.0.1c-4ubuntu8 i386 Secure Socket Layer (SSL) binary and related cryptographic tools
ii python-openssl 0.13-2ubuntu3 i386 Python 2 wrapper around the OpenSSL library

It appears that the software is there. Can someone help me on this? I tried to run the permissions file and downloaded the latest version for my distro.

Thanks in advance!

Dokter Computer
Find all posts by this user
Quote this message in a reply
05-20-2013, 11:12 AM
Post: #2
RE: [WP 2.1.1] AES function not available???
As per the installation instructions (http://whatpulse.org/kb/content/7/15/en/...ion.html), you need openssl-devel (or libssl-devl). Install that and you're good to go!
Visit this user's website Find all posts by this user
Quote this message in a reply
05-20-2013, 07:47 PM
Post: #3
RE: [WP 2.1.1] AES function not available???

Thanks, it worked. At first I could not find the packages mentioned but I found what I needed.

For other users having this problem execute this command:

sudo apt-get install libssl-dev

And you are good to go.

Once again, thanks.
Find all posts by this user
Quote this message in a reply
Post Reply 

Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  [SOLVED] WhatPulse Refuses to Start automatically. iisacc 11 12,129 08-23-2021 09:45 PM
Last Post: Tealdragon204
Question [SOLVED] Manual Pulse-button does not work PeaceFreak 5 3,535 03-13-2020 04:14 PM
Last Post: PeaceFreak
  [SOLVED] Can't run the Linux version [Driver not loaded Driver not loaded] radioz 2 4,216 06-20-2019 11:54 AM
Last Post: radioz
  [SOLVED] Error uploading keyboard/mouse heatmap Wopian 2 3,470 03-17-2017 12:26 PM
Last Post: Wopian
  [SOLVED] [postmortem] Pulse error: "The specified configuration cannot be used." dgw 4 5,456 03-03-2017 09:54 PM
Last Post: dgw
  [SOLVED] Client crashes on startup v. 2.7 Win10x64 Lttngblt 11 9,066 10-08-2016 06:43 PM
Last Post: smitmartijn
  [SOLVED] OS X no longer starts, crashes on startup stuthemonkey 3 3,450 10-01-2016 06:34 PM
Last Post: smitmartijn
  [SOLVED] Best solution for delaying whatpulse until after panel loads fennectech 1 2,982 09-15-2016 03:36 AM
Last Post: smitmartijn
Sad [SOLVED] The only thing that kept me from using whatpulse itzhalo 3 4,130 09-07-2016 09:53 AM
Last Post: smitmartijn
  [SOLVED] Facts window occassional displays strange formats/information d3ullist 1 3,030 07-08-2016 09:38 PM
Last Post: smitmartijn

Forum Jump:

User(s) browsing this thread: 1 Guest(s)