WhatPulse Forums » Support » Client software v » How must I install this? Welcome back, Guest.


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
How must I install this?
04-06-2013, 02:46 PM (This post was last modified: 04-19-2013 11:05 PM by nimd4.)
Post: #2
RE: How must I install this?
In order to install WhatPulse on Xubuntu:
  • check the requirements:
    • libQtCore
    • libQtWebKit
    • libqt4-sql
    • libqt4-sql-sqlite
    • openssl-devel
and/or:
  • apt-get install libqt4-core
    apt-get install libqtwebkit4
    apt-get install libqt4-sql-sqlite
    apt-get install libssl-dev
    apt-get install libpcap0.8
    apt-get install libpcap0.8-dev # the dev one was actually the one that made the "libpcap not available" - message go away....

Then start terminal in the folder where you unpacked the download (the script is simple, just enter to start it, type in the user, Ctrl-c of out it and reboot):

Code:
chmod +x setup-input-permissions.sh
sudo ./setup-input-permissions.sh

Next (run whatpulse from wherever you want, or use below, but setcap is needed for network stats):
Code:
sudo cp whatpulse /opt/whatpulse
sudo setcap cap_net_raw,cap_net_admin=eip /opt/whatpulse
sudo ln -s /opt/whatpulse /usr/local/bin/whatpulse
whatpulse

Either add whatpulse to your startup, or run it manually after the reboot (it should add itself).

PS.
As far as the network stats go, there are some threads, but as one of the devs posted - it's a known issue...

[Image: 2itq8g6.png]
^ This was cool xD
[Image: mcdty0-3.png]
Find all posts by this user
Quote this message in a reply
Post Reply 


Messages In This Thread
How must I install this? - satshow - 02-03-2013, 10:34 AM
RE: How must I install this? - nimd4 - 04-06-2013 02:46 PM
RE: How must I install this? - satshow - 04-28-2013, 08:09 AM

Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  Unable to install latest version: Certificate expired Gadgetdude 1 101 01-09-2020 10:32 AM
Last Post: smitmartijn
  WhatPulse 64bit install on Lubuntu 19.04 SiKTheGreatOne 0 610 06-30-2019 02:49 AM
Last Post: SiKTheGreatOne
  Whatpulse won't start, Unable to install crashRpt! Bai.Bing 0 439 05-24-2019 01:02 PM
Last Post: Bai.Bing
  [FIXED] Unable to Install 2.7 dj_chalky 2 1,089 06-01-2016 01:53 PM
Last Post: dj_chalky
  [SOLVED] how to install whatpulse on linux server hwebb 1 2,184 01-10-2015 12:11 PM
Last Post: smitmartijn
  install WP without root on linux mat.hi.as 6 4,252 05-06-2014 01:48 PM
Last Post: mat.hi.as
  Can't install WP for OSX Nouks 5 3,710 01-07-2014 01:34 PM
Last Post: Nouks
  Cant install the linux client BladeX 32 46,327 12-29-2012 05:38 PM
Last Post: nimd4
  Install guide? Bollivierke 1 1,307 12-01-2012 09:30 AM
Last Post: Bollivierke
  Can't install hjord 5 2,435 03-24-2011 10:27 PM
Last Post: jmrk

Forum Jump:


User(s) browsing this thread: 1 Guest(s)