WhatPulse Forums
WhatPulse 2.0 linux network traffic not working - Printable Version

+- WhatPulse Forums (http://whatpulse.org/forums)
+-- Forum: Support (/forumdisplay.php?fid=38)
+--- Forum: Client software (/forumdisplay.php?fid=58)
+--- Thread: WhatPulse 2.0 linux network traffic not working (/showthread.php?tid=2154)



WhatPulse 2.0 linux network traffic not working - houkouonchi - 12-29-2012 03:09 PM

I am not getting anything for network traffic on whatpulse 2.0. I am running it in a chroot environment but with sys, proc and other file-systems mounted in the chroot I would expect it to work ok. /proc/net/dev shows propper bytes received/sent stats.

I was wondering what the requirements were for this feature or how it worked to troubleshoot why it doesnt work for me:

[Image: whatpulse.png]
[Image: whatpulse_2.png]
[Image: whatpulse_3.png]
[Image: whatpulse_4.png]
[Image: whatpulse_5.png]


RE: WhatPulse 2.0 linux network traffic not working - eTheBlack - 12-29-2012 03:18 PM

I guess it is running thru sudo command? Might help to dev if you post which network card you are using.


RE: WhatPulse 2.0 linux network traffic not working - houkouonchi - 12-29-2012 03:18 PM

Ok so I guess it needed pcaputils installed not just the libpcap stuff. Unfortunately now whatpulse uses 25% of a single core as its likely pretty slow using pcap to look at data from ~100mbits or more of traffic I think an optino for a less detailed one that didnt need libpcap and just use /proc/net/dev or something would be nicer =(

Also it appears the speed is a bit off as well. I was downloading at > 30 megabytes/sec yet it only listed 23.9 and never even got above 30.

[Image: whatpulse_6.png]
[Image: whatpulse_7.png]


RE: WhatPulse 2.0 linux network traffic not working - nimd4 - 12-29-2012 04:55 PM

(12-29-2012 03:09 PM)houkouonchi Wrote:  I am not getting anything for network traffic on whatpulse 2.0.

Any particular reason to make a double-post?

Code:
http://whatpulse.org/forums/showthread.php?tid=2036

Edit: or even a triple. Smile

PS.
(12-29-2012 03:18 PM)houkouonchi Wrote:  pcaputils
Still no-go here. :\


RE: WhatPulse 2.0 linux network traffic not working - houkouonchi - 12-29-2012 06:21 PM

(12-29-2012 04:55 PM)nimd4 Wrote:  
(12-29-2012 03:09 PM)houkouonchi Wrote:  I am not getting anything for network traffic on whatpulse 2.0.

Any particular reason to make a double-post?

Code:
http://whatpulse.org/forums/showthread.php?tid=2036

Edit: or even a triple. Smile

PS.
(12-29-2012 03:18 PM)houkouonchi Wrote:  pcaputils
Still no-go here. :\

That was not a double post the other thread you could say was a double post because I posted there *after* I posted here because I saw other people reporting the same issue I mentioned in this post. I did not make a triple post so no clue what your talking about there.

I think its appropriate to make a double post in another thread when you see its the same issue your reporting in your thread.


RE: WhatPulse 2.0 linux network traffic not working - MAX3400 - 12-29-2012 07:06 PM

Don't think it is about who posts where but more a matter of "if we keep all same OS related issues in 1 or maybe 2 topics, it leads to quicker resolution, answers and even attention from developers".

There are already tons of people posting the same on Windows and their powersaving; I don't even answer anymore; both from their and my laziness to dig tru the other topics that exist with exactly the same error.

And the same goes for Linux; so far WhatPulse seems to work only on recent (in my opinion unstable) releases of a certain distro; for any other distro it doesn't work or relies on unstable sources or needs a lot of fiddling. Maybe the Linux-minded people can stick together and find a workable solution for the mainstream distro's out there by bundling our remarks, finds and issues Smile

That said, your screenshots show 12.04LTS but unsure what desktop, dependencies and packages came with it. I am running 12.04LTS as well but didn't have to install the other pcap-packages you talked about. Maybe, if you care, find out & post why you needed extra packages over the standard libpcap0.8 & dev?


RE: WhatPulse 2.0 linux network traffic not working - houkouonchi - 12-30-2012 01:47 AM

Kinda hard to say what is required when its just some binary executable. All i know is it did not work until I also had pcap-utils.

I am running it out of an chroot like I peviously mentioned. The chroot is pretty much just a bare-bones ubuntu install, nothing special. My actual distro is gentoo but I have a chroot environment setup for programs that are not source based and require ubuntu to work properly (like steam).

I have to say that full-blown packet capturing was a bad route to go (IMHO). I get they can get more details and stuff but it makes it much much more CPU intensive not to mention from what I have seen very inaccurate/under reported numbers.


RE: WhatPulse 2.0 linux network traffic not working - Sn0opy - 12-30-2012 08:57 AM

I don't think pcap-utils has to be used for this. Even tools like vnstat don't need it.

By the way, the same issue exists on OSX.


RE: WhatPulse 2.0 linux network traffic not working - FamilienVater - 12-30-2012 03:06 PM

the packets are filtered, so internal and local traffic does not count...
as far as I know, the other - less CPU-intensive - tools only take the raw counters the network cards/drivers provide...
(I think that approach would be better, too... - although it will generate huge numbers for some of us Wink )