WhatPulse Forums » Support » Client software v » [CLOSED] Whatpulse does not work with libssl-dev 1.1.0 Welcome back, Guest.


Thread Closed 
 
Thread Rating:
  • 6 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[CLOSED] Whatpulse does not work with libssl-dev 1.1.0
12-12-2016, 09:57 PM (This post was last modified: 08-17-2017 01:26 PM by smitmartijn.)
Post: #1
[CLOSED] Whatpulse does not work with libssl-dev 1.1.0
Greetings,

This has started happening on two different computers both running Debian Testing:

Whatpulse 2.7.1 fails with the message "AES functions not available. Is OpenSSL library present?"

Normally, this seems to be a failure to have libssl-dev installed. I have libssl-dev 1.1.0 installed.

[Edited] I have downgraded to libssl-dev 1.0.1 and Whatpulse runs perfectly again - but to continue counting keystrokes, I had to pulse, then delete my local data files and start afresh.

Jonathan
Find all posts by this user
01-08-2017, 09:07 PM
Post: #2
RE: [Edited] Whatpulse does not work with libssl-dev 1.1.0
I'm getting exactly the same issue on Kali Linux. Not much point in reverting to libssl-dev 1.0.1 either because of dependencies.
Find all posts by this user
01-09-2017, 05:44 PM
Post: #3
RE: [Edited] Whatpulse does not work with libssl-dev 1.1.0
I'm having the same issue, also on debian testing. The worst thing is that since whatpulse doesn't run, I won't be notified when they'll release 2.7.2 which will hopefully fix the error.
Find all posts by this user
02-27-2017, 05:26 PM
Post: #4
RE: [Edited] Whatpulse does not work with libssl-dev 1.1.0
The latest debian version still seems to be used libssl 1.0.0. Same goes for Ubuntu. This means the next client version will still be linked to libssl 1.0.0.

What happens when you symlink the new libssl.so.1.1.0 to the old libssl.so.1.0.0?
Visit this user's website Find all posts by this user
03-07-2017, 11:11 PM
Post: #5
RE: [Edited] Whatpulse does not work with libssl-dev 1.1.0
Problem i have is when i upgrade Kali OS it installs libssl-dev 1.1.0, will have to see if i can install 1.0.0 alongside 1.1.0 without breaking stuff
Find all posts by this user
04-25-2017, 09:11 PM
Post: #6
AES functions not available. Arch Linux
I just upgraded my system and am unable to launch the client software. I definitely have openssl installed and have not changed anything with the system, apart from updating it. What can I do to get whatpulse to work correctly again?
Find all posts by this user
05-03-2017, 04:04 PM
Post: #7
RE: AES functions not available. Arch Linux
Same problem, tried some tricks with LD_PRELOAD, tried ldd, installing openssl-compat libraries. Nothing worked. What function calls is the whatpulse using to try the OpenSSL availability?
Find all posts by this user
05-04-2017, 08:58 AM
Post: #8
RE: AES functions not available. Arch Linux
yup has been broken now for over a week Sad
Find all posts by this user
05-05-2017, 10:04 AM
Post: #9
RE: AES functions not available. Arch Linux
I've tried various things as well, such as using files from the openssl-1.0.0 package. Tracing with strace and ltrace. We would need the authors on this I think.
Find all posts by this user
05-10-2017, 04:56 PM
Post: #10
RE: AES functions not available. Arch Linux
I've had the same problem for a few weeks now, nothing I have attempted has been able to fix it.
Find all posts by this user
Thread Closed 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
Brick WhatPulse 2.8.4 not counting keystrokes _Incqption 0 222 12-12-2018 12:41 PM
Last Post: _Incqption
Brick Pulsing doesn't work - 2.8.3 Shavot 2 920 07-08-2018 11:18 PM
Last Post: Shavot
Exclamation [Workaround, Not Solved] Pulsing Not Working, v2.8.3, Win10 fAEth 5 1,920 05-06-2018 07:47 AM
Last Post: smitmartijn
  Pulsing doesn't work Vetselm 2 1,325 04-14-2018 06:56 PM
Last Post: smitmartijn
  [FIXED] WhatPulse 2.8.2 is not counting keys on Mac iOChris 1 1,184 02-27-2018 04:14 PM
Last Post: iOChris
Bug [CLOSED] No keys recorded since last week Thursday Aasdf00as8df 4 2,855 02-18-2018 12:27 AM
Last Post: smitmartijn
  [CLOSED] Huge difference traffic counter numbers in overview and account tabs knagie 4 1,885 02-11-2018 12:45 PM
Last Post: smitmartijn
  [CLOSED] MacOS: Key from A-Z0-9 aren't acounted anymore Sn0opy 2 1,303 02-04-2018 07:52 PM
Last Post: Sn0opy
  [CLOSED] Resolution problems unaigil99 1 1,096 01-26-2018 06:17 PM
Last Post: smitmartijn
  [CLOSED] Windows 7 latest update and WhatPulse JetSet 2 1,730 01-21-2018 05:39 PM
Last Post: JetSet

Forum Jump:


User(s) browsing this thread: 1 Guest(s)