WhatPulse Forums » Support » Client software v » v. 2.2 doesn't count internet traffic correctly Welcome back, Guest.


Post Reply 
 
Thread Rating:
  • 1 Votes - 4 Average
  • 1
  • 2
  • 3
  • 4
  • 5
v. 2.2 doesn't count internet traffic correctly
09-17-2013, 09:26 PM (This post was last modified: 09-17-2013 09:27 PM by nimd4.)
Post: #11
RE: v. 2.2 doesn't count internet traffic correctly
(09-16-2013 08:16 PM)eTheBlack Wrote:  Here you can get 2.0.1 version:

Maybe you can, but I wouldn't. Without MD5 and/or SHA checksum(s) for the original files, imo it's not such a hot idea to download this program from a third-party web site. ;-)

.. but, no joke, for real.

Code:
https://en.wikipedia.org/wiki/Checksum

[Image: 2itq8g6.png]
^ This was cool xD
[Image: mcdty0-3.png]
Find all posts by this user
Quote this message in a reply
09-17-2013, 11:49 PM
Post: #12
RE: v. 2.2 doesn't count internet traffic correctly
(09-17-2013 09:26 PM)nimd4 Wrote:  
(09-16-2013 08:16 PM)eTheBlack Wrote:  Here you can get 2.0.1 version:

Maybe you can, but I wouldn't. Without MD5 and/or SHA checksum(s) for the original files, imo it's not such a hot idea to download this program from a third-party web site. ;-)

.. but, no joke, for real.

Code:
https://en.wikipedia.org/wiki/Checksum

I download from this site then made a backup there. If you don't want, then don't download. Just helping to fix this thing
Find all posts by this user
Quote this message in a reply
09-18-2013, 08:50 AM (This post was last modified: 09-18-2013 12:17 PM by whatthenaiser.)
Post: #13
RE: v. 2.2 doesn't count internet traffic correctly
my fritzbox shows me 33840 MB upload.
and i only see 15gb upload in wp-app.

so: version 2.0.1 misses half of the traffic, too.

in my opinion wp thinks that lot of p2p traffic is internal and doesnt count it.
i have no problem while i'm downloading something in my browser. maybe there are rules based on ip addresses and some ip ranges are internal for wp?



I tested to download something from my server. wp on my server shows my only 330 kb/s upload, and my download pc shows my a download over 500 kb/s.

here is a screenshot:
https://www.dropbox.com/s/6ue0lx86vima60...nannt2.png
Find all posts by this user
Quote this message in a reply
09-24-2013, 01:09 PM
Post: #14
RE: v. 2.2 doesn't count internet traffic correctly
Dear All,

I'm currently facing the same issues here. WP 2.2 and 2.2.1 only captures a small slice of the real traffic. WP 2.1 works well, as long as i have a VPN connection established.

My PC is online with a global routable IP (e.g. 90.91.92.93/24) and the traffic I generate is not to computers on the same local network (like 90.91.93.0/24).

I've attached two screenshots. The screen throughput from WP 2.1 differs from the system monitor because of the spikes, this is not important.


Attached File(s)
.png  Bildschirmfoto vom 2013-09-24 14-06-47.png (Size: 342.13 KB / Downloads: 232)
.png  Bildschirmfoto vom 2013-09-24 14-12-18.png (Size: 358.66 KB / Downloads: 244)
Find all posts by this user
Quote this message in a reply
11-09-2013, 08:22 PM
Post: #15
RE: v. 2.2 doesn't count internet traffic correctly
There have been a lot of improvements to the performance of the networking measurements lately..anyone willing to give it a go, please try the latest build: http://whatpulse.org/forums/showthread.php?tid=3862

Tested up to 400Mbit p/s of normal and p2p traffic, but then again, our own tests have always gone properly.
Visit this user's website Find all posts by this user
Quote this message in a reply
11-09-2013, 08:43 PM
Post: #16
RE: v. 2.2 doesn't count internet traffic correctly
okay, thx for your answer.
i tested it with a random torrent client and than i downloaded and share a linux os.
Find all posts by this user
Quote this message in a reply
11-10-2013, 03:35 AM (This post was last modified: 11-25-2013 05:20 PM by JumpinJohnny.)
Post: #17
RE: v. 2.2 doesn't count internet traffic correctly
Excellent work on 2.3b1 ... It finally works for me, tracking uploads and downloads ... so far no glitches.
It's tracking my browser and my P2P at the same time and all while using VPN.
Just what I wanted it to do.Smile
...............................................................
edit:
ooOPS ... spoke too soon Undecided

only worked for a day partially, then stopped counting network traffic both ways after 3-4 days
I've tried re-installing under quite a few scenarios, (see above posts).
Still nada
all the same issues.
Find all posts by this user
Quote this message in a reply
11-10-2013, 10:26 AM
Post: #18
RE: v. 2.2 doesn't count internet traffic correctly
(11-09-2013 08:43 PM)whatthenaiser Wrote:  i tested it with a random torrent client and than i downloaded and share a linux os.

And what were the outcomes of those tests? ;-)

@JumpinJohnny: thanks!
Visit this user's website Find all posts by this user
Quote this message in a reply
12-22-2013, 08:04 PM (This post was last modified: 12-22-2013 08:45 PM by FamilienVater.)
Post: #19
RE: v. 2.2 doesn't count internet traffic correctly
I just found a setting that fixed the problem for me...

I uploaded with 10MB per second (100MBit) and WhatPulse only showed around a few 100kB per second.
This is caused by a feature of modern (and/or "older" but more expensive) network adapters called TCP (Segmentation) Offloading (TSO)[1]. It basically allows the operating system and/or software to send huge packets to the network adaptor which itself breaks them down to smaller ones without letting the CPU do that overhead.
Disabling it solved the problem.

So I guess Pcap only counts those larger packets as one standard size packet which would explain the difference.

Will try to disable this with my linux machine as well - I was only able to do this under win7 yet.

Here is the fix for linux (this has to be done after each boot):
Code:
ethtool -K eth0 tso off
ethtool -K eth0 gso off

-- this actually takes a moment to kick in since current connections are still in the old mode if you enable this...


Your Mileage My Vary Smile


[1] http://en.wikipedia.org/wiki/TCP_segmentation_offload
Find all posts by this user
Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  Whatpulse is not recognizing internet traffic Lodisen 8 1,365 05-22-2019 05:35 PM
Last Post: Trapton
  [CLOSED] Network traffic not recorded on Ubuntu 16.04 LTS GnaXi 4 1,839 09-15-2016 03:33 AM
Last Post: smitmartijn
  ALT Combinations are not detected correctly. Fightglor 0 666 09-11-2016 11:30 AM
Last Post: Fightglor
  [CLOSED] Does WhatPulse and the WinPCap driver slow down internet? dandu3 2 1,631 08-06-2016 12:45 AM
Last Post: dandu3
  [CLOSED] Mac client, network traffic reading but not pulsing dacheat 1 1,081 05-23-2016 02:11 PM
Last Post: smitmartijn
  doesn't recognize keys Posergoth6667 1 1,135 05-09-2016 04:56 PM
Last Post: mupi
  Uptime not tracking correctly (windows 10) RuneRifle 0 961 05-05-2016 11:04 PM
Last Post: RuneRifle
  WhatPulse not seeing that I'm connected to the internet Code-E 0 996 05-01-2016 06:34 PM
Last Post: Divisi
  Upload not measured correctly Electrosa 2 1,478 04-03-2016 05:56 PM
Last Post: kubo25
  [SOLVED] Windows 10, WinPcap and Internet traffic Sm00chY 7 5,004 03-21-2016 05:50 PM
Last Post: Wynand

Forum Jump:


User(s) browsing this thread: 1 Guest(s)