WhatPulse Forums » Community » Beta client » Archive v » Windows b6 - program freeze issue (Windows XP and XP64) Welcome back, Guest.


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Windows b6 - program freeze issue (Windows XP and XP64)
11-15-2012, 01:48 PM
Post: #1
Windows b6 - program freeze issue (Windows XP and XP64)
Hi all,

I've encountered a strange behaviour:

I've upgraded some of my Windows PCs (most of them are at least dual-boot Wink ) to b6 and with all of them, the following happened:

I switched off "per application" and "per country" stats
I clicked on save
the program instantly froze (no excess CPU usage however)
after killing it with the task manager and restarting it, the whatpulse.exe shows as a task but no task bar icon and no program window appears.
even after a reboot, the process/task appears, but nothing else. even after hours of waiting...

-----

another thing I've noticed: before the freeze issue, whatpulse would need a significant time to start. I've set it to load the main window on start. It's 5 minutes or even more...

maybe this is related...
Find all posts by this user
Quote this message in a reply
11-15-2012, 06:06 PM
Post: #2
Windows b6 - program freeze issue (Windows XP and XP64)
Have a look in C:\Users\%USERNAME%\AppData\Local\WhatPulse - is there a whatpulse.db-wal file and how big is it?

If it is pretty large, that will be the cause - we're looking into that now.
Visit this user's website Find all posts by this user
Quote this message in a reply
11-16-2012, 12:50 AM
Post: #3
Windows b6 - program freeze issue (Windows XP and XP64)
Hmmm.. it's actually located in:

I:\Documents and Settings\%USERNAME%\Local Settings\Application Data\Whatpulse\

and has only 55MB. I've used WinXP for at least 6 hours today... and the Program did not start...


On the same Machine, using Vista, the file has 2GB size and WP needs "only" about 5 minutes to start and works...
Find all posts by this user
Quote this message in a reply
11-16-2012, 09:27 AM (This post was last modified: 11-16-2012 09:27 AM by sibberio.)
Post: #4
Windows b6 - program freeze issue (Windows XP and XP64)
My file is 2GB.
Any news about the next beta?
Any roadmap?
Just to know Smile
Find all posts by this user
Quote this message in a reply
11-22-2012, 01:59 AM (This post was last modified: 11-22-2012 02:08 AM by FamilienVater.)
Post: #5
Windows b6 - program freeze issue (Windows XP and XP64)
Still having the same problem with b7, tested on WinXP64 this time...

First I installed over the old beta and tried to start it -> only the process shows.
Then I killed the process and removed all the files in I:\Documents and Settings\%USER%\Local Settings\Application Data\WhatPulse\
WP did start this time and prompted me with my credentials etc. but after changing settings and hitting "save", the program froze and I had to kill it again. Restarting it keeps it in the process list but nothing happens...

Do you need additional information? should I investigate further in some direction?


[edit]

Aaaah, I just tried the settings individually, got the error and tested again and had it again (so it's reproducible):

1.) Unsetting "Uptime \ Per application"
2.) save (works)
3.) Unsetting "Network \ Per application"
4.) save (works)
5.) unsetting "Network \ Per country"
6.) save (freeze)

Even if you go straight ahead for "per country" it freezes afterwards. -- My current workaround: keeping it enabled Wink
Find all posts by this user
Quote this message in a reply
11-24-2012, 03:07 PM
Post: #6
Windows b6 - program freeze issue (Windows XP and XP64)
I was going to ask to try a build with something disabled. You can ignore my PM now that I've seen your edit though. I've been able to reproduce the freeze now, so I can fix it. Thanks!
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  Windows Beta 7 Crash X-Kal 3 7,851 12-04-2012 09:52 PM
Last Post: X-Kal
  DLL errors on Windows XP sibberio 5 5,998 11-26-2012 09:35 AM
Last Post: sibberio
  Windows b7 - Small Network Tab Problem Alakon9x 2 3,795 11-25-2012 08:43 AM
Last Post: smitmartijn
  Mac issue tim95 2 2,491 11-24-2012 05:08 PM
Last Post: smitmartijn
  Windows b5 client bugs sellyme 53 39,811 11-12-2012 09:51 PM
Last Post: wfps_105
  Windows b6 disk consumption Syfaro 6 5,640 11-08-2012 11:08 PM
Last Post: Syfaro
  Windows b6 - Crash On hibernate Alakon9x 3 4,745 11-06-2012 07:05 PM
Last Post: Alakon9x
  Windows b6 - Heatmap Issue Alakon9x 7 6,361 11-06-2012 06:58 PM
Last Post: Alakon9x
  Windows b6 - Network FamilienVater 4 4,683 10-30-2012 05:56 PM
Last Post: smitmartijn

Forum Jump:


User(s) browsing this thread: 1 Guest(s)